<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" lang="en-US" xml:lang="en-US" prefix="og: http://ogp.me/ns#">
<head profile="http://gmpg.org/xfn/11">
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<meta name="viewport" content="width=device-width; initial-scale=1.0" />
<meta name="msvalidate.01" content="67E7CE9DCF90E368DBA06E0A0341922D" />
<title>Speaker on U.S. in Afghanistan at MHS Jan. 23 - Ferndale Record | Ferndale Record</title>
<link rel="profile" href="https://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="https://www.ferndalerecord.com/wp-content/themes/publisher/style.css" />
<link rel="alternate" type="application/rss+xml" title="Ferndale Record RSS Feed" href="https://www.ferndalerecord.com/feed/" />
<link rel="alternate" type="application/atom+xml" title="Ferndale Record Atom Feed" href="https://www.ferndalerecord.com/feed/atom/" />
<link rel="pingback" href="https://www.ferndalerecord.com/xmlrpc.php" />
<link rel="stylesheet" type="text/css" href="https://www.ferndalerecord.com/wp-content/themes/publisher/colors/ferndalerecord.css" />
<link rel="stylesheet" type="text/css" href="https://www.ferndalerecord.com/wp-content/themes/publisher/custom.css" />

<link rel="canonical" href="https://www.ferndalerecord.com/speaker-on-u-s-in-afghanistan-at-mhs-jan-23/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Speaker on U.S. in Afghanistan at MHS Jan. 23 - Ferndale Record" />
<meta property="og:description" content="Jim McKinney is retired Army veteran   WHATCOM — Lt. Col. (Ret.) Jim McKinney, a U.S. Army veteran and local resident, will talk Wednesday, Jan. 23, about his recent contract deployment to Afghanistan and the relevance of the war there to the United States and Whatcom County   McKinney will speak at 6:30 p.m. in Meridian High &hellip;" />
<meta property="og:url" content="https://www.ferndalerecord.com/speaker-on-u-s-in-afghanistan-at-mhs-jan-23/" />
<meta property="og:site_name" content="Ferndale Record" />
<meta property="article:publisher" content="https://www.facebook.com/ferndalerecord/" />
<meta property="article:section" content="News" />
<meta property="article:published_time" content="2019-01-16T10:29:04-08:00" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:description" content="Jim McKinney is retired Army veteran   WHATCOM — Lt. Col. (Ret.) Jim McKinney, a U.S. Army veteran and local resident, will talk Wednesday, Jan. 23, about his recent contract deployment to Afghanistan and the relevance of the war there to the United States and Whatcom County   McKinney will speak at 6:30 p.m. in Meridian High [&hellip;]" />
<meta name="twitter:title" content="Speaker on U.S. in Afghanistan at MHS Jan. 23 - Ferndale Record" />
<meta name="twitter:site" content="@FerndaleRecord" />
<meta name="twitter:creator" content="@FerndaleRecord" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/www.ferndalerecord.com\/","sameAs":["https:\/\/www.facebook.com\/ferndalerecord\/","https:\/\/twitter.com\/FerndaleRecord"],"@id":"https:\/\/www.ferndalerecord.com\/#organization","name":"Ferndale Record","logo":"https:\/\/www.ferndalerecord.com\/wp-content\/uploads\/2018\/09\/FerndaleRecord.gif"}</script>

<link rel='dns-prefetch' href='//platform-api.sharethis.com' />
<link rel='dns-prefetch' href='//use.fontawesome.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Ferndale Record &raquo; Feed" href="https://www.ferndalerecord.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Ferndale Record &raquo; Comments Feed" href="https://www.ferndalerecord.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Ferndale Record &raquo; Speaker on U.S. in Afghanistan at MHS Jan. 23 Comments Feed" href="https://www.ferndalerecord.com/speaker-on-u-s-in-afghanistan-at-mhs-jan-23/feed/" />
<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/www.ferndalerecord.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=b117460373fc1fbe762dc75167a8e239"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
<meta content="/mnt/stor2-wc1-dfw1/411056/805628/www.ferndalerecord.com/web/content/wp-content/themes/publisher/style.css v." name="generator" /><style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='pmpro_frontend-css' href='https://www.ferndalerecord.com/wp-content/plugins/paid-memberships-pro/css/frontend.css?ver=1.9.5.6' type='text/css' media='screen' />
<link rel='stylesheet' id='pmpro_print-css' href='https://www.ferndalerecord.com/wp-content/plugins/paid-memberships-pro/css/print.css?ver=1.9.5.6' type='text/css' media='print' />
<link rel='stylesheet' id='shortcodes-css' href='https://www.ferndalerecord.com/wp-content/themes/publisher/functions/shortcodes/shortcodes.css?ver=b117460373fc1fbe762dc75167a8e239' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css' href='https://www.ferndalerecord.com/wp-includes/css/dist/block-library/style.min.css?ver=b117460373fc1fbe762dc75167a8e239' type='text/css' media='all' />
<link rel='stylesheet' id='theme-my-login-css' href='https://www.ferndalerecord.com/wp-content/plugins/theme-my-login/assets/styles/theme-my-login.min.css?ver=7.0.12' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp_font_awesome-css' href='https://use.fontawesome.com/releases/v5.5.0/css/all.css?ver=b117460373fc1fbe762dc75167a8e239' type='text/css' media='all' />
<link rel='stylesheet' id='wpbdp-widgets-css' href="https://www.ferndalerecord.com/wp-content/plugins/business-directory-plugin/assets/css/widgets.min.css?ver=5.4" type='text/css' media='all' />
<link rel='stylesheet' id='default-styles-css' href="https://www.ferndalerecord.com/wp-content/plugins/business-directory-plugin/themes/default/assets/styles.css?ver=4.0.4" type='text/css' media='all' />
<link rel='stylesheet' id='awpcp-frontend-style-css' href="https://www.ferndalerecord.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle.css?ver=3.9.3" type='text/css' media='all' />
<!--[if lte IE 6]>
<link rel='stylesheet' id='awpcp-frontend-style-ie-6-css'  href='http://www.ferndalerecord.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-ie-6.css?ver=3.9.3' type='text/css' media='all' />
<![endif]-->
<!--[if lte IE 7]>
<link rel='stylesheet' id='awpcp-frontend-style-lte-ie-7-css'  href='http://www.ferndalerecord.com/wp-content/plugins/another-wordpress-classifieds-plugin/resources/css/awpcpstyle-lte-ie-7.css?ver=3.9.3' type='text/css' media='all' />
<![endif]-->
<script type='text/javascript' src='https://www.ferndalerecord.com/wp-content/themes/publisher/includes/js/jquery.min.js?ver=1.10.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var samAjax = {"ajaxurl":"https:\/\/www.ferndalerecord.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax.php","loadurl":"https:\/\/www.ferndalerecord.com\/wp-content\/plugins\/simple-ads-manager\/sam-ajax-loader.php","load":"","mailer":"1","clauses":"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","doStats":"1","container":"sam-container","place":"sam-place","ad":"sam-ad"};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ferndalerecord.com/wp-content/plugins/simple-ads-manager/js/sam-layout.min.js?ver=2.9.7.123'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var themeMyLogin = {"action":"","errors":[]};
/* ]]> */
</script>
<script type='text/javascript' src='https://www.ferndalerecord.com/wp-content/plugins/theme-my-login/assets/scripts/theme-my-login.min.js?ver=7.0.12'></script>
<script type='text/javascript' src='//platform-api.sharethis.com/js/sharethis.js#product=ga&#038;property=5ab03806a63ccf001315afcd'></script>
<script type='text/javascript' src='https://www.ferndalerecord.com/wp-content/themes/publisher/functions/shortcodes/shortcodes.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://www.ferndalerecord.com/wp-content/themes/publisher/includes/js/jquery.jcarousel.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://www.ferndalerecord.com/wp-content/themes/publisher/includes/js/superfish.js?ver=1.5.8'></script>
<script type='text/javascript' src='https://www.ferndalerecord.com/wp-content/themes/publisher/includes/js/custom.js?ver=1.4.2'></script>
<script type='text/javascript' src='https://www.ferndalerecord.com/wp-content/themes/publisher/includes/js/jquery-ui-1.8.5.custom.min.js?ver=1.8.5'></script>
<link rel='https://api.w.org/' href='https://www.ferndalerecord.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://www.ferndalerecord.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://www.ferndalerecord.com/wp-includes/wlwmanifest.xml" />
<link rel='shortlink' href='https://www.ferndalerecord.com/?p=11659' />
<link rel="alternate" type="application/json+oembed" href="https://www.ferndalerecord.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ferndalerecord.com%2Fspeaker-on-u-s-in-afghanistan-at-mhs-jan-23%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://www.ferndalerecord.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwww.ferndalerecord.com%2Fspeaker-on-u-s-in-afghanistan-at-mhs-jan-23%2F&#038;format=xml" />
<script type="text/javascript">
(function(url){
	if(/(?:Chrome\/26\.0\.1410\.63 Safari\/537\.31|WordfenceTestMonBot)/.test(navigator.userAgent)){ return; }
	var addEvent = function(evt, handler) {
		if (window.addEventListener) {
			document.addEventListener(evt, handler, false);
		} else if (window.attachEvent) {
			document.attachEvent('on' + evt, handler);
		}
	};
	var removeEvent = function(evt, handler) {
		if (window.removeEventListener) {
			document.removeEventListener(evt, handler, false);
		} else if (window.detachEvent) {
			document.detachEvent('on' + evt, handler);
		}
	};
	var evts = 'contextmenu dblclick drag dragend dragenter dragleave dragover dragstart drop keydown keypress keyup mousedown mousemove mouseout mouseover mouseup mousewheel scroll'.split(' ');
	var logHuman = function() {
		if (window.wfLogHumanRan) { return; }
		window.wfLogHumanRan = true;
		var wfscr = document.createElement('script');
		wfscr.type = 'text/javascript';
		wfscr.async = true;
		wfscr.src = url + '&r=' + Math.random();
		(document.getElementsByTagName('head')[0]||document.getElementsByTagName('body')[0]).appendChild(wfscr);
		for (var i = 0; i < evts.length; i++) {
			removeEvent(evts[i], logHuman);
		}
	};
	for (var i = 0; i < evts.length; i++) {
		addEvent(evts[i], logHuman);
	}
})('//www.ferndalerecord.com/?wordfence_lh=1&hid=1301A2AA03C6DB4DC111399FF2432C88');
</script><link rel="shortcut icon" href="https://www.ferndalerecord.com/wp-content/themes/publisher/images/favicon2.png" />
<style type="text/css">
body { }
</style>
<script type="text/javascript">
	jQuery(document).ready(function() {
	    jQuery('#mycarousel').jcarousel({
		    visible: 3,
		    scroll: 3
	    });
	});
</script>
</head>
<body class="post-template-default single single-post postid-11659 single-format-standard pmpro-body-level-required pmpro-body-level-7 pmpro-body-level-6 pmpro-body-level-1 pmpro-body-level-3 pmpro-body-level-4 pmpro-body-level-2 pmpro-body-level-5 pmpro-body-level-8 pmpro-body-level-9 unknown wpbdp-with-button-styles">
<div id="wrapper">
<div class="inner-wrap">
<div id="header">
<a href="https://www.ferndalerecord.com"><img src="https://www.ferndalerecord.com/wp-content/themes/publisher/images/logo.png" alt="Ferndale Record" id="logo" /></a>
<div class="header-ad">
<div id='c9949_153_4' class='sam-container sam-place' data-sam='1'><a id='a43_153' class='sam_ad' href='https://www.silverreefcasino.com/gamingpromotions/#/promo/1' target='_blank'><img src='https://www.ferndalerecord.com/wp-content/uploads/2019/01/NYNM-600x90.png' alt='silver reef casino new year new money' /></a></div>
</div>
<div class="clear"></div>
</div>
<div id="primary-nav">
<ul id="primary-navigation" class="nav"><li id="menu-item-7930" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7930"><a href="https://www.ferndalerecord.com/category/news/">News</a>
<ul class="sub-menu">
<li id="menu-item-7931" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7931"><a href="https://www.ferndalerecord.com/category/business/">Business</a></li>
<li id="menu-item-7936" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7936"><a href="https://www.ferndalerecord.com/category/education/">Education</a></li>
</ul>
</li>
<li id="menu-item-7933" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7933"><a href="https://www.ferndalerecord.com/category/community/">Community</a>
<ul class="sub-menu">
<li id="menu-item-7934" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7934"><a href="https://www.ferndalerecord.com/category/arts/">Arts &#038; Entertainment</a></li>
<li id="menu-item-7935" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7935"><a href="https://www.ferndalerecord.com/category/blogs/">Blogs</a></li>
<li id="menu-item-7937" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7937"><a href="https://www.ferndalerecord.com/category/obituaries/">Obituaries</a></li>
<li id="menu-item-7932" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7932"><a href="https://www.ferndalerecord.com/category/opinion/">Opinion</a></li>
</ul>
</li>
<li id="menu-item-7939" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7939"><a href="https://www.ferndalerecord.com/category/sports/">Sports</a></li>
<li id="menu-item-7938" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7938"><a href="https://www.ferndalerecord.com/category/legals/">Legals</a></li>
<li id="menu-item-102" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-102"><a href="https://www.ferndalerecord.com/classifieds-2/">Classifieds</a>
<ul class="sub-menu">
<li id="menu-item-100" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-100"><a href="https://www.ferndalerecord.com/view-online-classifieds/">View Online Classifieds</a></li>
</ul>
</li>
<li id="menu-item-295" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-295"><a href="https://ferndalerecord.com/#">Special Sections</a>
<ul class="sub-menu">
<li id="menu-item-2149" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-2149"><a target="_blank" href="https://www.ferndalerecord.com/special-sections/country-life/">Country Life</a></li>
<li id="menu-item-6684" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-6684"><a target="_blank" href="https://www.ferndalerecord.com/special-sections/drive-whatcom/">Drive Whatcom</a></li>
<li id="menu-item-6792" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-6792"><a target="_blank" href="https://www.ferndalerecord.com/special-sections/el-periodico/">El Periódico</a></li>
<li id="menu-item-9946" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-9946"><a target="_blank" href="https://www.ferndalerecord.com/special-sections/everson-nooksack-news/">Everson-Nooksack News</a></li>
<li id="menu-item-304" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-304"><a target="_blank" href="https://www.ferndalerecord.com/special-sections/encore-2/">Encore</a></li>
<li id="menu-item-6685" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-6685"><a target="_blank" href="https://www.ferndalerecord.com/special-sections/homeandgarden/">Home &#038; Garden</a></li>
<li id="menu-item-6686" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-6686"><a target="_blank" href="https://www.ferndalerecord.com/special-sections/sports-preview/">Sports Preview</a></li>
<li id="menu-item-2135" class="ppr-new-window menu-item menu-item-type-post_type menu-item-object-page menu-item-2135"><a target="_blank" href="https://www.ferndalerecord.com/special-sections/whatcomcoupons/">Whatcom County Coupons</a></li>
<li id="menu-item-6683" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-6683"><a href="https://www.ferndalerecord.com/special-sections/annual_publications/">Annual Publications</a></li>
</ul>
</li>
<li id="menu-item-7940" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7940"><a href="https://www.ferndalerecord.com/business-directory/">Go Local Directory</a></li>
<li id="menu-item-8041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-8041"><a href="https://www.ferndalerecord.com/contact-us/">Contact Us</a></li>
<li><a rel="nofollow" href="https://www.ferndalerecord.com/login/">Log in</a></li></ul> </div>
<div id="secondary-nav">
<ul id="secondary-navigation" class="nav"><li id="menu-item-7926" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7926"><a href="https://www.ferndalerecord.com/advertising/">Advertising</a></li>
<li id="menu-item-7929" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7929"><a href="https://www.ferndalerecord.com/subscribe/">Subscribe</a></li>
<li id="menu-item-7942" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-7942"><a href="https://www.ferndalerecord.com/submissions/">Submissions</a>
<ul class="sub-menu">
<li id="menu-item-7944" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7944"><a href="https://www.ferndalerecord.com/submissions/anniversary-announcement/">Anniversary Announcement</a></li>
<li id="menu-item-7948" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7948"><a href="https://www.ferndalerecord.com/submissions/birth-announcement/">Birth Announcement</a></li>
<li id="menu-item-7950" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7950"><a href="https://www.ferndalerecord.com/submissions/birthday-announcement/">Birthday Announcement</a></li>
<li id="menu-item-7952" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7952"><a href="https://www.ferndalerecord.com/submissions/engagement-announcement/">Engagement Announcement</a></li>
<li id="menu-item-7960" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7960"><a href="https://www.ferndalerecord.com/submissions/letter-to-the-editor/">Letter to the Editor</a></li>
<li id="menu-item-7954" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7954"><a href="https://www.ferndalerecord.com/submissions/obituary-submission/">Obituary Submission</a></li>
<li id="menu-item-7943" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7943"><a href="https://www.ferndalerecord.com/submissions/275-2/">Submit Classifieds</a></li>
<li id="menu-item-7967" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7967"><a href="https://www.ferndalerecord.com/submissions/submit-event/">Submit Event</a></li>
<li id="menu-item-7957" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7957"><a href="https://www.ferndalerecord.com/submissions/marriage-announcement/">Wedding/Marriage Announcement</a></li>
</ul>
</li>
<li><a rel="nofollow" href="https://www.ferndalerecord.com/login/">Log in</a></li></ul> </div>
<div id="container">
<div id="content">
<div id="breadcrumbs">
<a href="https://www.ferndalerecord.com">Ferndale Record</a>
<a href="https://www.ferndalerecord.com/category/news/">News</a> Speaker on U.S. in Afghanistan at MHS Jan. 23
</div>
<div id="post-11659" class="post-11659 post type-post status-publish format-standard hentry category-news pmpro-level-required pmpro-level-7 pmpro-level-6 pmpro-level-1 pmpro-level-3 pmpro-level-4 pmpro-level-2 pmpro-level-5 pmpro-level-8 pmpro-level-9 pmpro-no-access">
<h1 class="entry-title">Speaker on U.S. in Afghanistan at MHS Jan. 23</h1>
<div class="entry-meta">
<a href="https://www.ferndalerecord.com/author/blindquist/" title="Posts by Brent Lindquist" rel="author">Brent Lindquist</a> 
</div>
<div class="entry-content">
<p>Jim McKinney is retired Army veteran   WHATCOM — Lt. Col. (Ret.) Jim McKinney, a U.S. Army veteran and local resident, will talk Wednesday, Jan. 23, about his recent contract deployment to Afghanistan and the relevance of the war there to the United States and Whatcom County   McKinney will speak at 6:30 p.m. in Meridian High&#8230; </p>
<div class="pmpro_content_message">
<p>This content is for subscribers only. Already a subscriber? <a href="/wp-login.php?redirect_to=https%3A%2F%2Fwww.ferndalerecord.com%2Fspeaker-on-u-s-in-afghanistan-at-mhs-jan-23%2F">Login</a> or <a href="/wp-login.php?action=register">Subscribe Now</a></p>
</div>

<p><center>
<script type="text/javascript"><!--
google_ad_client = "ca-pub-1838627375717879";
/* 468x60 Tribune Banner */
google_ad_slot = "1228131710";
google_ad_width = 468;
google_ad_height = 60;
//-->
</script>
<script type="text/javascript" src="https://pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</center>
</p>

<div class="clear"></div>

</div>
</div>
<div class="clear"></div>
<div class="authorbox">
<p><img alt='' src='https://secure.gravatar.com/avatar/021ddba7c1b24cc381339cbd2e802729?s=48&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/021ddba7c1b24cc381339cbd2e802729?s=96&#038;d=mm&#038;r=g 2x' class='avatar avatar-48 photo' height='48' width='48' /> <strong><a href="https://www.ferndalerecord.com/author/blindquist/" title="Posts by Brent Lindquist" rel="author">Brent Lindquist</a></strong><br />
Email Brent at <a href="/cdn-cgi/l/email-protection#0e606b797d4e686b7c606a6f626b7c6b6d617c6a206d6163"><span class="__cf_email__" data-cfemail="fd93988a8ebd9b988f93999c91988f989e928f99d39e9290">[email&#160;protected]</span></a></p>
<div class="clear"></div>
</div>
</div>
<div id="sidebar" name="https://www.ferndalerecord.com/wp-content/themes/publisher">
<div id="search-2" class="widget widget_search"><form method="get" id="searchform" action="https://www.ferndalerecord.com">
<input type="text" class="field" name="s" id="s" value="Search…" onfocus="if (this.value == 'Search…') {this.value = '';}" onblur="if (this.value == '') {this.value = 'Search…';}" />
</form>
</div><div id="simple_ads_manager_block_widget-2" class="widget simple_ads_manager_block_widget"><div class=' sam-block sam-block-lines-3 sam-block-cols-1'><div class='sam-block-line' style='margin: 0px; padding: 0px;'><div class='sam-block-item' style='display: inline-block; margin: ; padding: 0px 0px 10px 0px; background: #FFFFFF; border: 0px solid'><div id='c8808__' class='sam-container sam-ad'></div></div></div><div class='sam-block-line' style='margin: 0px; padding: 0px;'><div class='sam-block-item' style='display: inline-block; margin: ; padding: 0px 0px 10px 0px; background: #FFFFFF; border: 0px solid'><div id='c8128_152_1' class='sam-container sam-place' data-sam='0'><a id='a39_152' class='sam_ad' href='https://www.whatcomymca.org' target='_blank'><img src='https://www.ferndalerecord.com/wp-content/uploads/2018/12/YMCA-RJ-ONLINE-Jan-2019-no-joining-fee.png' alt='whatcom ymca no joining fee january 2019' /></a></div></div></div><div class='sam-block-line' style='margin: 0px; padding: 0px;'><div class='sam-block-item' style='display: inline-block; margin: ; padding: 0px 0px 10px 0px; background: #FFFFFF; border: 0px solid'><div id='c6189_99_1' class='sam-container sam-place' data-sam='0'><a id='a90_99' class='sam_ad' href='https://www.classy.org/checkout/donation?eid=112436' target='_blank'><img src='https://www.ferndalerecord.com/wp-content/uploads/2018/03/April-Ferndale-Ad-2018.jpg' alt='lighthouse mission care for the hungry' /></a></div></div></div></div></div><div id="archives-2" class="widget widget_archive"><h3 class="widget-title"><span>Archives</span></h3> <ul>
<li><a href='https://www.ferndalerecord.com/2019/01/'>January 2019</a></li>
<li><a href='https://www.ferndalerecord.com/2018/12/'>December 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/11/'>November 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/10/'>October 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/09/'>September 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/08/'>August 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/07/'>July 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/06/'>June 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/05/'>May 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/04/'>April 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/03/'>March 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/02/'>February 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2018/01/'>January 2018</a></li>
<li><a href='https://www.ferndalerecord.com/2017/12/'>December 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/11/'>November 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/10/'>October 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/09/'>September 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/08/'>August 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/07/'>July 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/06/'>June 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/05/'>May 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/04/'>April 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/03/'>March 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/02/'>February 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2017/01/'>January 2017</a></li>
<li><a href='https://www.ferndalerecord.com/2016/12/'>December 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/11/'>November 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/10/'>October 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/09/'>September 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/08/'>August 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/07/'>July 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/06/'>June 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/05/'>May 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/04/'>April 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/03/'>March 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/02/'>February 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2016/01/'>January 2016</a></li>
<li><a href='https://www.ferndalerecord.com/2015/12/'>December 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/11/'>November 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/10/'>October 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/09/'>September 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/08/'>August 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/07/'>July 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/06/'>June 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/05/'>May 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/04/'>April 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/03/'>March 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/02/'>February 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2015/01/'>January 2015</a></li>
<li><a href='https://www.ferndalerecord.com/2014/12/'>December 2014</a></li>
</ul>
</div></div> </div>
<div class="clear"></div>
</div>
<div id="footer">
<div class="copyright">
<div class="left">
&copy; 2019 <a href="https://www.ferndalerecord.com" title="" rel="home">Ferndale Record</a>. All rights reserved.
</div>
<div class="right">
  </div>
<div class="clear"></div>
</div>
</div>
<div class="clear"></div>
</div> 

<script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script>
    jQuery(document).ready(function () {
		jQuery.post('https://www.ferndalerecord.com?ga_action=googleanalytics_get_script', {action: 'googleanalytics_get_script'}, function(response) {
			var s = document.createElement("script");
			s.type = "text/javascript";
			s.innerHTML = response;
			jQuery("head").append(s);
		});
    });
</script><script type='text/javascript' src='https://www.ferndalerecord.com/wp-includes/js/comment-reply.min.js?ver=b117460373fc1fbe762dc75167a8e239'></script>
<script type='text/javascript' src='https://www.ferndalerecord.com/wp-includes/js/wp-embed.min.js?ver=b117460373fc1fbe762dc75167a8e239'></script>
<style type="text/css"></style></body>
</html>